标签归档:centos

CentOS6系统”libc.so.6: version ‘GLIBC_2.15’ not found”解决方法

出现”libc.so.6: version ‘GLIBC_2.15’ not found”问题,是由于glibc版本过低,升级glibc即可。
可以将解决CentOS系统GLIBC_2.12版本低的问题
由于CentOS系统RPM源目前glibc最高版本是2.12,所以只能采用源码升级
一、查看系统glibc支持的版本

    strings /lib64/libc.so.6 |grep GLIBC  
    #查看当前glibc版本  
    ll /lib64/libc.so.6   
    lrwxrwxrwx. 1 root root 12 Oct  9  2014 /lib64/libc.so.6 -> libc-2.12.so  

二、下载glibc源码包

    cd /usr/src/  
    wget http://mirror.bjtu.edu.cn/gnu/glibc/glibc-2.15.tar.gz  
    wget http://mirror.bjtu.edu.cn/gnu/glibc/glibc-ports-2.15.tar.gz      #glibc插件  

三、解压安装升级glibc

    tar zxvf glibc-2.15.tar.gz  
    tar zxvf glibc-ports-2.15.tar.gz  
    mv glibc-ports-2.15 glibc-2.15/ports  
    mkdir build  
    cd build  
    ../glibc-2.15/configure  --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin  
    make -j4  
    make install  

四、验证

查看当前系统glibc支持的版本

    strings /lib64/libc.so.6 |grep GLIBC  

五、误删libc.so.6解决办法

命令行执行如下:

LD_PRELOAD=/lib/libc-2.12.so ln -s /lib/libc-2.12.so lib/libc.so.6

来源:http://blog.csdn.net/hnhuangyiyang/article/details/50392997

CentOS 6下VNC 配置方法

VNC是一款优秀的远程控制工具

  VNC是一款优秀的远程控制工具软件,由著名的AT&T的欧洲研究实验室开发的。VNC是在基于UNIX和Linux操作系统的免费的开放源码软件,远程控制能力强大,高效实用,其性能可以和Windows和MAC中的任何远程控制软件媲美。

  首先是安装了 CentOS 6.0 的 64 位版。本文讲解的是一种方法。VNC 配置网上搜了有很多,但是貌似写的都不够基础,这里仔细按步骤记录一下。

一、安装 VNC

  首先检查一下本机是否安装了 VNC,默认情况下,CentOS 6.0 是没有安装的。

  检查是否安装,输入:

[root@localhost ~]# rpm -q vnc vnc-server

  得到:

package vnc is not installed

package vnc-server is not installed

  提示没有安装,那么就开始安装,输入:

[root@localhost ~]# yum install vnc vnc-server

  注:如果是 Ubuntu 则输入:

[root@localhost ~]# apt-get install vnc vnc-server

  在一串指令提示后,会让你确认一些选项,输入两次 “Y” 并确认,稍作等待,提示 “Complete!” 即完成安装。

二、设置 VNC 密码

  启动 VNC,输入:

[root@localhost ~]# vncserver

  此时会提示你输入密码,因为是第一次配置。重复输入两次即可。
继续阅读